use strict;
my $str = '
<div class="tutu">
Blahblah.
<div class="whatever">
Blahblah0.
<div class="tata">
Blahblah1.
</div>
Blahblah2.
</div>
Blahblah3.
</div>
';
my $regex = qr/<div class="whatever">(.*?)(<div[^>]*>((?>(?:(?!<\/?div)[^\n])+|\n|(?2))*)<\/div>)(.*?)<\/div>/musp;
my $subst = '\\1\\2\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";