import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"<div class="whatever">(.*?)(<div[^>]*>((?>(?:(?!<\/?div)[^\n])+|\n|(?2))*)<\/div>)(.*?)<\/div>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
<div class="tutu">
Blahblah.
<div class="whatever">
Blahblah0.
<div class="tata">
Blahblah1.
</div>
Blahblah2.
</div>
Blahblah3.
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)