#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mus)<div class="whatever">(.*?)(<div[^>]*>((?>(?:(?!<\/?div)[^\n])+|\n|(?2))*)<\/div>)(.*?)<\/div>"
Local $sString = "" & @CRLF & _
" <div class="tutu">" & @CRLF & _
" Blahblah." & @CRLF & _
" <div class="whatever">" & @CRLF & _
" Blahblah0." & @CRLF & _
" <div class="tata">" & @CRLF & _
" Blahblah1." & @CRLF & _
" </div>" & @CRLF & _
" Blahblah2." & @CRLF & _
" </div>" & @CRLF & _
" Blahblah3." & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\1\2\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)