using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""whatever"">(.*?)(<div[^>]*>((?>(?:(?!<\/?div)[^\n])+|\n|(?2))*)<\/div>)(.*?)<\/div>";
string substitution = @"\1\2\4";
string input = @"
<div class=""tutu"">
Blahblah.
<div class=""whatever"">
Blahblah0.
<div class=""tata"">
Blahblah1.
</div>
Blahblah2.
</div>
Blahblah3.
</div>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}