const regex = /<div class="whatever">(.*?)(<div[^>]*>((?>(?:(?!<\/?div)[^\n])+|\n|(?2))*)<\/div>)(.*?)<\/div>/gmus;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="whatever">(.*?)(<div[^>]*>((?>(?:(?!<\\\/?div)[^\\n])+|\\n|(?2))*)<\\\/div>)(.*?)<\\\/div>', 'gmus')
const str = `
<div class="tutu">
Blahblah.
<div class="whatever">
Blahblah0.
<div class="tata">
Blahblah1.
</div>
Blahblah2.
</div>
Blahblah3.
</div>
`;
const subst = `\1\2\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);