re = /<div class="whatever">(.*?)(<div[^>]*>((?>(?:(?!<\/?div)[^\n])+|\n|(?2))*)<\/div>)(.*?)<\/div>/m
str = '
<div class="tutu">
Blahblah.
<div class="whatever">
Blahblah0.
<div class="tata">
Blahblah1.
</div>
Blahblah2.
</div>
Blahblah3.
</div>
'
subst = '\\1\\2\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result