$re = '/<div class="whatever">(.*?)(<div[^>]*>((?>(?:(?!<\/?div)[^\n])+|\n|(?2))*)<\/div>)(.*?)<\/div>/mus';
$str = '
<div class="tutu">
Blahblah.
<div class="whatever">
Blahblah0.
<div class="tata">
Blahblah1.
</div>
Blahblah2.
</div>
Blahblah3.
</div>
';
$subst = "\1\2\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;