# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(([[0|1]\d)|(2[0-3]))[:]?([0-5]\d)$//gmi;t' <<< "12
1300
1459
1760
2567
3382
2400
23:59"