$re = '/^(([[0|1]\d)|(2[0-3]))[:]?([0-5]\d)$/mi';
$str = '12
1300
1459
1760
2567
3382
2400
23:59';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;