use strict;
my $str = '12
1300
1459
1760
2567
3382
2400
23:59';
my $regex = qr/^(([[0|1]\d)|(2[0-3]))[:]?([0-5]\d)$/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";