// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(([[0|1]\d)|(2[0-3]))[:]?([0-5]\d)$").unwrap();
let string = "12
1300
1459
1760
2567
3382
2400
23:59";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}