using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([[0|1]\d)|(2[0-3]))[:]?([0-5]\d)$";
string substitution = @"";
string input = @"12
1300
1459
1760
2567
3382
2400
23:59";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}