#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^(([[0|1]\d)|(2[0-3]))[:]?([0-5]\d)$"
Local $sString = "12" & @CRLF & _
"1300" & @CRLF & _
"1459" & @CRLF & _
"1760" & @CRLF & _
"2567" & @CRLF & _
"3382" & @CRLF & _
"2400" & @CRLF & _
"23:59"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)