const regex = /^(([[0|1]\d)|(2[0-3]))[:]?([0-5]\d)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([[0|1]\\d)|(2[0-3]))[:]?([0-5]\\d)$', 'gmi')
const str = `12
1300
1459
1760
2567
3382
2400
23:59`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);