package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(([[0|1]\d)|(2[0-3]))[:]?([0-5]\d)$`)
var str = `12
1300
1459
1760
2567
3382
2400
23:59`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}