#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?:(?<=[+\-*/^%()])-)?\d+(?!\d)|[+\-*/^%()])(?!$)"
Local $sString = "(5+4+8--5)+(5^-2/(-23%2))"
Local $sSubst = "$1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)