$re = '`((?:(?<=[+\-*/^%()])-)?\d+(?!\d)|[+\-*/^%()])(?!$)`';
$str = '(5+4+8--5)+(5^-2/(-23%2))';
$subst = "$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;