use strict;
my $str = '(5+4+8--5)+(5^-2/(-23%2))';
my $regex = qr`((?:(?<=[+\-*/^%()])-)?\d+(?!\d)|[+\-*/^%()])(?!$)`p;
my $subst = '$1 ';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";