import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?<=[+\\-*/^%()])-)?\\d+(?!\\d)|[+\\-*/^%()])(?!$)";
final String string = "(5+4+8--5)+(5^-2/(-23%2))";
final String subst = "$1 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}