const regex = new RegExp('((?:(?<=[+\\-*/^%()])-)?\\d+(?!\\d)|[+\\-*/^%()])(?!$)', 'g')
const str = `(5+4+8--5)+(5^-2/(-23%2))`;
const subst = `$1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);