import re
regex = re.compile(r"((?:(?<=[+\-*/^%()])-)?\d+(?!\d)|[+\-*/^%()])(?!$)")
test_str = "(5+4+8--5)+(5^-2/(-23%2))"
subst = "$1 "
result = regex.sub(subst, test_str)
if result:
print(result)