using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:(?<=[+\-*/^%()])-)?\d+(?!\d)|[+\-*/^%()])(?!$)";
string substitution = @"$1 ";
string input = @"(5+4+8--5)+(5^-2/(-23%2))";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}