# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=>[^<]*)(flyer)|(flyer)(?=[^>]*<)/<u>$1$2<\/u>/gi;t' <<< "flyertalk.com <a href=\"HTTPS://flyertalk.com\">Flyer Talk website</a>
Forum <a href=\"HTTPS://www.flyertalk.com/forum/delta-air-lines-skymiles-665/\">Delta</a>
----- <a href=\"HTTPS://www.flyertalk.com/forum/american-airlines-aadvantage-733/\">AAA</a>
<u>Pneu</u> FLYER
- FLYER 40-622 <a href=\"HTTPS://www.veloplus.ch/AlleProdukte/Reifen/CityTourAlltag.aspx\">TUB</a> FLYER"