import Foundation
let pattern = #"(?<=>[^<]*)(flyer)|(flyer)(?=[^>]*<)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
flyertalk.com <a href="HTTPS://flyertalk.com">Flyer Talk website</a>
Forum <a href="HTTPS://www.flyertalk.com/forum/delta-air-lines-skymiles-665/">Delta</a>
----- <a href="HTTPS://www.flyertalk.com/forum/american-airlines-aadvantage-733/">AAA</a>
<u>Pneu</u> FLYER
- FLYER 40-622 <a href="HTTPS://www.veloplus.ch/AlleProdukte/Reifen/CityTourAlltag.aspx">TUB</a> FLYER
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<u>$1$2</u>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)