import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=>[^<]*)(flyer)|(flyer)(?=[^>]*<)";
final String string = "flyertalk.com <a href=\"HTTPS://flyertalk.com\">Flyer Talk website</a>\n"
+ "Forum <a href=\"HTTPS://www.flyertalk.com/forum/delta-air-lines-skymiles-665/\">Delta</a>\n"
+ "----- <a href=\"HTTPS://www.flyertalk.com/forum/american-airlines-aadvantage-733/\">AAA</a>\n"
+ "<u>Pneu</u> FLYER\n"
+ "- FLYER 40-622 <a href=\"HTTPS://www.veloplus.ch/AlleProdukte/Reifen/CityTourAlltag.aspx\">TUB</a> FLYER";
final String subst = "<u>$1$2</u>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}