re = /(?<=>[^<]*)(flyer)|(flyer)(?=[^>]*<)/i
str = 'flyertalk.com <a href="HTTPS://flyertalk.com">Flyer Talk website</a>
Forum <a href="HTTPS://www.flyertalk.com/forum/delta-air-lines-skymiles-665/">Delta</a>
----- <a href="HTTPS://www.flyertalk.com/forum/american-airlines-aadvantage-733/">AAA</a>
<u>Pneu</u> FLYER
- FLYER 40-622 <a href="HTTPS://www.veloplus.ch/AlleProdukte/Reifen/CityTourAlltag.aspx">TUB</a> FLYER'
subst = '<u>$1$2</u>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result