import re
regex = re.compile(r"(?<=>[^<]*)(flyer)|(flyer)(?=[^>]*<)", flags=re.IGNORECASE)
test_str = ("flyertalk.com <a href=\"HTTPS://flyertalk.com\">Flyer Talk website</a>\n"
"Forum <a href=\"HTTPS://www.flyertalk.com/forum/delta-air-lines-skymiles-665/\">Delta</a>\n"
"----- <a href=\"HTTPS://www.flyertalk.com/forum/american-airlines-aadvantage-733/\">AAA</a>\n"
"<u>Pneu</u> FLYER\n"
"- FLYER 40-622 <a href=\"HTTPS://www.veloplus.ch/AlleProdukte/Reifen/CityTourAlltag.aspx\">TUB</a> FLYER")
subst = "<u>$1$2</u>"
result = regex.sub(subst, test_str)
if result:
print(result)