const regex = /(?<=>[^<]*)(flyer)|(flyer)(?=[^>]*<)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=>[^<]*)(flyer)|(flyer)(?=[^>]*<)', 'gi')
const str = `flyertalk.com <a href="HTTPS://flyertalk.com">Flyer Talk website</a>
Forum <a href="HTTPS://www.flyertalk.com/forum/delta-air-lines-skymiles-665/">Delta</a>
----- <a href="HTTPS://www.flyertalk.com/forum/american-airlines-aadvantage-733/">AAA</a>
<u>Pneu</u> FLYER
- FLYER 40-622 <a href="HTTPS://www.veloplus.ch/AlleProdukte/Reifen/CityTourAlltag.aspx">TUB</a> FLYER`;
const subst = `<u>$1$2</u>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);