#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mU)(^[^:]*(?=:)).+=(.*)(?:--|;){0,2}(.*)$"
Local $sString = "sig_map: bit_vector(27 downto 0):=x"0211111"" & @CRLF & _
"sig_map: bit_vector(27 downto 0):=x"0211111";" & @CRLF & _
"input_freq: real := 200.0;--comment text" & @CRLF & _
"dll_lock: integer:=dll_lock_time(sim_mode)--comment text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")