import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[^:]*(?=:)).+=(.*)(?:--|;){0,2}(.*)$";
final String string = "sig_map: bit_vector(27 downto 0):=x\"0211111\"\n"
+ "sig_map: bit_vector(27 downto 0):=x\"0211111\";\n"
+ "input_freq: real := 200.0;--comment text\n"
+ "dll_lock: integer:=dll_lock_time(sim_mode)--comment text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}