use strict;
my $str = 'sig_map: bit_vector(27 downto 0):=x"0211111"
sig_map: bit_vector(27 downto 0):=x"0211111";
input_freq: real := 200.0;--comment text
dll_lock: integer:=dll_lock_time(sim_mode)--comment text';
my $regex = qr/(^[^:]*(?=:)).+=(.*)(?:--|;){0,2}(.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}