$re = '/(^[^:]*(?=:)).+=(.*)(?:--|;){0,2}(.*)$/mU';
$str = 'sig_map: bit_vector(27 downto 0):=x"0211111"
sig_map: bit_vector(27 downto 0):=x"0211111";
input_freq: real := 200.0;--comment text
dll_lock: integer:=dll_lock_time(sim_mode)--comment text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);