re = /(^[^:]*(?=:)).+=(.*)(?:--|;){0,2}(.*)$/m
str = 'sig_map: bit_vector(27 downto 0):=x"0211111"
sig_map: bit_vector(27 downto 0):=x"0211111";
input_freq: real := 200.0;--comment text
dll_lock: integer:=dll_lock_time(sim_mode)--comment text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end