const regex = /(^[^:]*(?=:)).+=(.*)(?:--|;){0,2}(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[^:]*(?=:)).+=(.*)(?:--|;){0,2}(.*)$', 'gm')
const str = `sig_map: bit_vector(27 downto 0):=x"0211111"
sig_map: bit_vector(27 downto 0):=x"0211111";
input_freq: real := 200.0;--comment text
dll_lock: integer:=dll_lock_time(sim_mode)--comment text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}