using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[^:]*(?=:)).+=(.*)(?:--|;){0,2}(.*)$";
string input = @"sig_map: bit_vector(27 downto 0):=x""0211111""
sig_map: bit_vector(27 downto 0):=x""0211111"";
input_freq: real := 200.0;--comment text
dll_lock: integer:=dll_lock_time(sim_mode)--comment text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}