import re
regex = re.compile(r"(^[^:]*(?=:)).+=(.*)(?:--|;){0,2}(.*)$", flags=re.MULTILINE)
test_str = ("sig_map: bit_vector(27 downto 0):=x\"0211111\"\n"
"sig_map: bit_vector(27 downto 0):=x\"0211111\";\n"
"input_freq: real := 200.0;--comment text\n"
"dll_lock: integer:=dll_lock_time(sim_mode)--comment text")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")