#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<td\s+class="inline-rating-sm"\s+data-ci="\d*">\s+\(\d+\)<\/td>"
Local $sString = "<td class="inline-rating-sm" data-ci="943"> (150)</td>" & @CRLF & _
"<td class="inline-rating-sm" data-ci="922"> (66)</td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")