const regex = /<td\s+class="inline-rating-sm"\s+data-ci="\d*">\s+\(\d+\)<\/td>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<td\\s+class="inline-rating-sm"\\s+data-ci="\\d*">\\s+\\(\\d+\\)<\\\/td>', 'gm')
const str = `<td class="inline-rating-sm" data-ci="943"> (150)</td>
<td class="inline-rating-sm" data-ci="922"> (66)</td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}