$re = '/<td\s+class="inline-rating-sm"\s+data-ci="\d*">\s+\(\d+\)<\/td>/m';
$str = '<td class="inline-rating-sm" data-ci="943"> (150)</td>
<td class="inline-rating-sm" data-ci="922"> (66)</td>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);