using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<td\s+class=""inline-rating-sm""\s+data-ci=""\d*"">\s+\(\d+\)<\/td>";
string input = @"<td class=""inline-rating-sm"" data-ci=""943""> (150)</td>
<td class=""inline-rating-sm"" data-ci=""922""> (66)</td>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}