re = /<td\s+class="inline-rating-sm"\s+data-ci="\d*">\s+\(\d+\)<\/td>/m
str = '<td class="inline-rating-sm" data-ci="943"> (150)</td>
<td class="inline-rating-sm" data-ci="922"> (66)</td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end