package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<td\s+class="inline-rating-sm"\s+data-ci="\d*">\s+\(\d+\)<\/td>`)
var str = `<td class="inline-rating-sm" data-ci="943"> (150)</td>
<td class="inline-rating-sm" data-ci="922"> (66)</td>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}