// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<td\s+class="inline-rating-sm"\s+data-ci="\d*">\s+\(\d+\)<\/td>"#).unwrap();
let string = "<td class=\"inline-rating-sm\" data-ci=\"943\"> (150)</td>
<td class=\"inline-rating-sm\" data-ci=\"922\"> (66)</td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}