import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td\\s+class=\"inline-rating-sm\"\\s+data-ci=\"\\d*\">\\s+\\(\\d+\\)<\\/td>";
final String string = "<td class=\"inline-rating-sm\" data-ci=\"943\"> (150)</td>\n"
+ "<td class=\"inline-rating-sm\" data-ci=\"922\"> (66)</td>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}