#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bPassword\sarchivio:\s\d+\n\n\nPer\sconto\sdi:\s"
Local $sString = "" & @CRLF & _
"Password archivio: 6646" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Per conto di: pec@pec.anekitalia.com" & @CRLF & _
"posta-certificata@telecompost.it"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")