import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bPassword\\sarchivio:\\s\\d+\\n\\n\\nPer\\sconto\\sdi:\\s";
final String string = "\n"
+ "Password archivio: 6646\n\n\n"
+ "Per conto di: pec@pec.anekitalia.com\n"
+ "posta-certificata@telecompost.it";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}