import re
regex = re.compile(r"\bPassword\sarchivio:\s\d+\n\n\nPer\sconto\sdi:\s", flags=re.MULTILINE)
test_str = ("\n"
"Password archivio: 6646\n\n\n"
"Per conto di: pec@pec.anekitalia.com\n"
"posta-certificata@telecompost.it")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")