using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bPassword\sarchivio:\s\d+\n\n\nPer\sconto\sdi:\s";
string input = @"
Password archivio: 6646
Per conto di: pec@pec.anekitalia.com
posta-certificata@telecompost.it";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}