// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bPassword\sarchivio:\s\d+\n\n\nPer\sconto\sdi:\s").unwrap();
let string = "
Password archivio: 6646
Per conto di: pec@pec.anekitalia.com
posta-certificata@telecompost.it";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}