$re = '/\bPassword\sarchivio:\s\d+\n\n\nPer\sconto\sdi:\s/m';
$str = '
Password archivio: 6646
Per conto di: pec@pec.anekitalia.com
posta-certificata@telecompost.it';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);